Back to overview
Resolved
System maintenance
Aug 3, 2026 at 9:30am UTC
–
Aug 3, 2026 at 9:31am UTC
Affected services
Proton Mainnet
Resolved
Aug 3, 2026 at 9:31am UTC
We will be performing a short maintenance approximately 1 minute.
Affected services
Created
Aug 3, 2026 at 9:31am UTC
Maintenance ended
Affected services